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1

OX Documents v7.8.0

1.1

Intention of this Document

This document provides an overview of the new features available in the OX
Documents v7.8.0 major release.
The purpose of this document is to help Open-Xchange customers and partners
understand the logic behind these changes, especially the reason for enhancements
in usability.

1.2

Design Goals of OX Documents v7.8.0

One of the key benefits of OX Documents is the ability to exchange documents in a
lossless way with MS Office users (known as “round-tripping”). In this scenario MS
Office users will not notice that a document has been edited or created with OX
Documents.
A complementary concept in OX Documents is to display the content of MS Office or
ODF files when it cannot be edited or created. Examples of this are page attributes or
header & footer, which were read-only in earlier releases.
This release of OX Documents focuses on allowing users to create and edit
advanced documents containing these kind of elements. For example: header &
footer, paragraph styles, page attributes, comments in OX Text and conditional
formatting in OX Spreadsheet.
OX Documents also introduces a new way to work with existing presentations. Users
can now present online using the new OX Presenter app.
A more detailed overview of all the improvements to OX Documents is provided in
the following chapters.
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2

General Improvements

2.1

Context Menus

A context menu is a lightweight menu that provides the user with a shortcut to actions
related to the selected object, or context, in which the menu was opened. Context
menus are now available in OX Document with a right-mouse-click on Desktop
platforms. They give users direct access to items that otherwise need more clicks.
Here is an example of a context menu in OX Text, which allows users to insert an
image, a text frame or comment without switching to the “Insert” tab.

Context menus are also available in OX Spreadsheet.
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A context menu can be dismissed by clicking outside of the menu or pressing the
ESC key.

2.2

Support for New Standard Folders

OX Drive introduces new standard folders for documents, music, pictures and videos.
OX Documents makes use of these new standard folders. Templates are stored in a
“Template” subfolder in the “Documents” folder. If a new document is saved as a
template, the default directory in the “Save as” dialog is this new template folder.

If a new picture is inserted into the document, the default directory in the “Insert
image” dialog is the new “Pictures” folder.

2.3

Global Template Folders

To improve template management in OX Documents it is now possible for the
context admin to define a global template directory. Templates saved in this readonly directory are automatically available to all users and can be selected in the OX
Text or OX Spreadsheet document portal.
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2.4

Open Document from Local File

To allow a smooth workflow with files on your local disk it is now possible in OX
Documents to directly upload a local file in the “Open document” dialog. This saves a
detour over OX Drive. Click the “Upload local file” button in the “Open document”
dialog.
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2.5

Borders for images

Images in OX Text and OX Spreadsheet can be visually enhanced with a number of
different border styles and border colors.

Image with different borders

2.6

New Color Picker on Small Devices

Due to its responsive design OX Documents automatically adapts to different display
sizes. Mobile devices also require a different approach to how features are laid out
on screen. For a better user experience on small devices OX Documents now has a
touch-device-specific color picker which includes a slider widget.

Color picker for large screens
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3

OX Text

3.1

Headers and Footers

Headers and footers are often used in longer documents to keep them organized and
make them easier to read. Text entered in the header or footer will appear at the top
or bottom of every page. OX Text was already able to display headers and footers in
documents. With this release of OX Text, it is now possible to edit or create headers
and footers.
3.1.1

Create Headers and Footers

To create a header or footer use the “Header & footer” icon in the “Insert” tab menu
or just double-click anywhere on the top or bottom margin of the page. You can also
use the keyboard shortcuts (Ctrl+Alt+PgUp/PgDn).

Type and format text in the header and footer the same way you do in the main
document. To create more visually interesting documents, you can also add images,
like a logo, to your header and footer.
To finish editing the header or footer, click “Close”. Alternatively, you can press the
“Esc” key or click in the main document. After you close the header or footer, it will
still be visible but appear dimmed. To edit it just double-click anywhere on the
dimmed header or footer again.
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3.1.2

Create Different Headers and Footers

By default, OX Text uses the same headers and footers on every page of a
document (option “Same across entire document”). For documents like booklets you
might want a different header and footer on the left or right side of the document. For
other documents it might be better to use a different header or footer for the first
page of a document. To customize how the header or footer appears in the
document, select one of the following options in the dropdown:
•

Same across entire document (default)

•

Different first page

•

Different even & odd pages

•

Different first, even & odd pages

3.1.3

Positioning of Headers and Footers

OX Text allows an easy adjustment of the horizontal position of information inside a
header and footer. For example, if you want to center a chapter title, or place it flush
with the right margin, there are two preset tab stops: centered and right aligned at the
right margin. So you just need to press the “TAB” key once to create a center-aligned
text in a header or footer. To create right-aligned text, press the “TAB” key once
more.
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Headers and footers in OX Text are positioned in the top and bottom margins of a
document. Only if the header or footer becomes too large vertically to fit in the margin
will it start expanding downward (for the header) and upward (for the footer),
reducing the space in the body of the document.

3.1.4

Navigate between Headers and Footers

Headers and footers are often edited together. To quickly switch between headers
and footers without scrolling up or down manually, there is now an option to directly
jump between headers and footers.

3.1.5

Remove Headers and Footers

To remove a header or footer, you must delete all the content from it. Once you
delete a single header or footer manually, that same header or footer will be removed
in the rest of the document. Removing a header or footer will not change the top and
bottom margin.
As a document can contain a number of different header and footer types, there is
also an option to remove all headers and footers in one step.
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3.2

Working with Comments

If you are reviewing a text and you want to give feedback or ask questions about a
document without changing the actual content, you can now work with comments in
OX Text.
Comments are shown on a grey shaded area in the right document margin so that
they do not cover text, or affect the layout of the document. The grey comment area
is only visible if the document contains comments.

Selecting a comment shows a colored line surrounding it, and a line connecting it to
the anchor point of the comment (see also “Viewing Options”).
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3.2.1

Add Comments

Select the text or table content you want to add a comment to and click the
“Comment” icon in the “Insert” tab.

A new comment is created in the right document margin, and connected by a colored
line with the anchor point of the comment. OX Text automatically adds the name of
the author, a color, a picture and a time stamp in the comment.

Text in comments can also be formatted with a few exceptions: For example the font
size of comments, or the alignment, cannot be changed in order to make readability
consistent.

3.2.2

Reply to a Comment

You can also reply to a comment using the “Reply” icon making it easier to follow the
conversation.

Each author is automatically allocated a different color. For easy user identification
this color is the same one that is used to highlight changes by that user in the
document via the track changes function.
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3.2.3

Delete Comments

Select a comment and use the delete-icon in the comment box to remove this
comment from the document.

To delete all comments at once in the document, click the “Delete all” icon in the
“Review” tab.

3.2.4

Navigate through Comments

You can quickly review comments by navigating from one comment to the next. On
the “Review” tab, click “Previous” or “Next” to move through your comments.
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3.2.5

Working with Long Comments

If a page contains many long comments, or one comment has a lot of text, it will be
shortened automatically. A shortened comment is indicated with a black, downward
facing, triangle. To expand, click the comment. Other comments are moved down if
necessary.

First comment shortened

3.2.6

First comment expanded

Viewing Options

To prevent users from inadvertently distributing documents that contain comments,
OX Text displays comments by default. What is more users can display comments in
different ways (“Markup”), including a hide all comments (option “Show no
comments”).

The option “Highlight all comments” displays all connection lines and anchor points in
the document. If you have a lot of comments and connection lines, they may become
distracting if you are trying to read the document.
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To keep the document clean the default in OX Text is to highlight only the selected
comment (“Highlight selected comment”). Only if the user inserts, edits or hovers
over a comment, will the colored line with the anchor point become visible.

View option “Highlight all comments”: All colored lines and anchors are visible
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View option “Highlight selected comments”: Only one line and anchor is visible

The option “Show bubble comments” is the default view on touch devices with limited
space. Comments are not shown in the right margin but indicated with a colored
balloon icon:
The color of the icon is associated with the person who made the comment or
changes in the text using the track changes function. This allows an easy
identification of the author of the comment. To review the comment tap the icon and
a bubble with the comment will appear, and the anchor of the comment in the
document will be highlighted.
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A conversation (threaded comments) is indicated with this icon:
With this viewing option, you can focus on reading the document and you only see
the comments that you want, when you want it.
Note: Clicking the name in a comment opens the Halo view with additional
information about this person. This allows you to check that person’s availability,
send an email or learn more about your latest appointments or conversations.
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3.2.7

Filtering Comments

If you are working on a document with other teammates there could be many
comments in a document. To make reviewing comments more manageable you can
filter comments. To view the comments that were made by a specific author, click
“Markup” in the “Review” tab, and then click the option “Comment authors”. Select
the author’s name whose comments you want to display and OX Text filters the
comments.

3.2.8

Exchange comments with MS Word users

One of the key benefits of OX Text is the ability to exchange documents in a lossless
way with MS Word users (“round-tripping”). This round-trip allows OX Text and MS
Word users to collaborate smoothly on the same document. This also applies to
comments. Documents with comments created in MS Word carry over in OX Text
and vice versa. Comments created in OX Text also show up as comments when
opened in Microsoft Office.
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Comments in OX Text

3.3

Same comments in MS Word 2016

Modify Page Settings

OX Text offers a new option in the “File” tab to modify page settings. Users can now
select the paper format, change the orientation of the page, or reduce or enlarge the
content of a page. It is now also possible to create custom paper size and page
margins.

3.4

Create User Defined Paragraph Styles

Paragraph styles determine the look of the text in a document. OX Text is able to reuse paragraph and table styles imported from the original Word document. Now it is
also possible to change styles and create new user defined paragraph styles.
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To create a new style from manually formatted text, click “Create new style” in the
“Paragraph style” dropdown:

You can also reach this option via the context menu.

Type a new name in the “Create paragraph style” dialog, which provides a preview of
the text selection.
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The new paragraph style is added to the list of paragraph styles and can now be
applied elsewhere in the document. To rename or delete this new paragraph style,
use the context menu.

3.5

Fields

With fields, users can add dynamic elements to a text document. For example, fields
are at work when a page number or date is displayed that automatically changes.
OX Text now displays fields inserted in Word or OpenOffice Writer documents
correctly. The following fields can even be updated to display up-to-date information:
•

Page number and number of pages used in headers and footers are
updated automatically

•

Page number and number of pages used in the main text can be updated
manually, like in Word

•

Current date and current time is updated automatically during document
load and print. Both fields can also be updated manually

•

File name can be update manually

To update a field manually, click the field and press F9 or use the context menu.
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3.6

Autofit for Text Frames

If you use text frames as a design element in your documents, they allow resizing of
your text. When the amount of text within the frame shrinks or grows, the height of
the text frame will automatically resize. If you resize the text frame manually in
vertical direction, the “Autosize” function is disabled.
Now you can enable this “Autosize” feature again after resizing a text frame with the
new option “Autofit”. The height of the text frame will automatically adjust.

Resized text frame

Text frame with “Autofit”
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4

OX Spreadsheet

4.1

Function Wizard

OX Spreadsheet offers a wide range of formulas that can be used for basic number
crunching, such as addition or subtraction, as well as more complex calculations,
such as finding the average on test results or calculating mortgage payments.
But how to find and use all the functions and formulas within OX Spreadsheet? Since
you might not be familiar with how some functions are structured, you can now use
the Function Wizard to assist you. To activate the Function Wizard, click the “Fx”
Function button in the “Insert” tab.

Select a category and all the functions that sit in there will be listed. You can now
look through this list, select a function and by looking at the description see if it meets
your needs. Choose the right function and click “Insert” to insert the function into a
cell. Enter the addresses of the required cells to be used in the function that fits the
syntax of the chosen function.
The Function Wizard also helps if you have a spreadsheet with a function in it that
you do not fully understand. If you click on the cell with the function you want to
understand, the Function Wizard pops up with the function argument and
explanation. This allows you to understand any function that is used in a
spreadsheet.
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To help users save time while searching for the right function, the Function Wizard
supports as-you-type suggestions in the function list. Functions are grouped in the
following categories:
•
•
•
•
•
•
•
•
•
•
•
•
•

4.2

All
Complex
Database
Date and time
Engineering
Financial
Information
Logical
Math
Matrix
Reference
Statistical
Text

Conditional Formatting

Sometimes it is hard to read and interpret data by scanning rows and rows of
information. Conditional formatting lets you differentiate data at a glance. For
example, it highlights important information in a cell that features a specific name or
date, or differentiates high, medium and low values.
OX Spreadsheet can now display conditional formatting from existing spreadsheet
documents. The following formatting rules are supported:
•
•
•
•
•
•

A formula expression resulting in true or false
Comparison rules (equal to, greater than, less than, etc.)
Text matching (contains, starts with, etc.)
Date matching (today, yesterday, next month, etc.)
Blank cells, error cells, duplicate cells, etc.
“Top 10” conditions, average conditions

A cell can also have more than one rule.
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A few examples for conditional formatting

Creating new conditional formatting rules is not possible yet and will be added in
future releases.

4.3

Named Cell Ranges

Named cell ranges allow you to give cell or group of cells a meaningful name that is
easy to read and remember. As a result, entering formulas becomes easier and
complex spreadsheets become more readable. For example, instead of using "C30"
to reference a cell (or "C30:C42" for a group of cells), you can name a cell or group
"Budget_total".
To create a range name, select the cell or range that you want to define. Click
“Named ranges” in the “Data” tab. This will open a popup window that allows you to
create and manage all your ranges. You can also access this popup by the context
menu.
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Click “Add new named range” and define your range name in the “Insert name”
dialog. The “Formula” field defines the range itself. If you highlighted cells before
adding a new named range, the range address will already be inserted. You can also
define the range manually by typing in this field. Click “Insert” to create the new
range. The new range will show up in the popup window.

If you hover over the name of the range in the popup, the range in the spreadsheet is
highlighted. To remove a named range, click the “Trash” icon.
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Calculating in OX Spreadsheet can now work with these named ranges instead of
cell ranges.

Named ranges in functions

4.4

Improved Performance

4.4.1

Painting with Canvas

Cell ranges in functions

OX Spreadsheet already used a canvas element to paint the grid and cell attributes
like borders and background. Now text is also rendered into an HTML canvas
element. This allows better performance when zooming, scrolling or changing
columns or rows.
4.4.2

Optimized Rendering for Retina Displays

Rendering in OX Spreadsheet also takes Retina displays into account so that
spreadsheet documents do not look pixelated and blurred on these devices.
4.4.3

Prefetch Views for Scroll Performance

This performance improvement affects scrolling in a spreadsheet. The view areas
above, below, right and left of the active sheet are prefetched and cached. If the user
starts scrolling, the view update now feels more responsive.
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5

Present Online

OX Documents introduces a new way to work with existing PowerPoint
presentations. Users can now not only view the presentation, but also present online
using the new OX Presenter app and broadcast their PowerPoint slides over the
web. Remote users can then follow along in their web browser.

5.1

Show PowerPoint Slides

OX App Suite v7.8.0 provides a new viewing overlay (see the OX App Suite What’s
New Guide) which also displays PowerPoint files. The focus of this viewing overlay is
to quickly consume any kind of data consistently, including presentations. Therefore
all slides of a PowerPoint file are displayed one below the other. This allows users to
quickly scroll through a presentation and consume the content.
If the user now decides to present these PowerPoint slides to local, or remote
attendees, he can start a presentation from within the viewing overlay with a new
option called “Present”.

5.1.1

How it Works

Clicking the “Present” icon starts the Presenter app and opens the PowerPoint file
automatically. The Presenter app allows you to navigate through the slides
horizontally via thumbnails, navigation buttons, keyboard shortcuts or clicking the
slide. The user can also zoom in and out and start a presentation.
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Two modes of presenting are supported: For face-to-face meetings use the “Start
local presentation” mode, which allows the presentation to be viewed in fullscreen. If
you have remote participants, use the remote presentation mode.
Starting a remote presentation switches the view to the Presenter view, which shows
the current and the next slide. This view also allows you to switch to full screen mode
and to end or pause the presentation. With the navigation bar at the bottom, users
can jump directly to a slide or check who is participating in the presentation.
Please make sure that all remote attendees have sufficient rights and access to the
URL of the PowerPoint file in OX Drive. You can send the URL of the file in the
Presenter view via email or use the new sharing feature (see OX App Suite What’s
New Guide).
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All remote participants who want to join the presentation and have this URL open,
receive a notification, that the presentation has started and that they now can join.

Joining the presentation switches the view to fullscreen. All remote participants will
now see the same slide and navigation in real time, and can follow along. The
presenter can see the names of all remote participants in the participant list. After the
presenter ends the meeting, all remote attendees receive a notification.
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Note: Fullscreen mode is not supported on iOS devices.
5.1.2

Using a Mobile Device as a Remote Control

Starting a remote presentation also makes sense for a local presentation if the
presenter wants to use two devices: a laptop for projecting and a mobile device for
navigating. In this scenario the presenter would start a remote presentation on the
mobile device and join the presentation with the laptop. The presenter can now use
the mobile device for navigating while the laptop projects the slides in fullscreen.
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